Este es el desarrollo del laboratorio OSPF número 2 para la asignatura de Configuración avanzada de redes (CCNP1).

Configurar las interfaces físicas y lógicas.

R1#conf t
R1(config)#int s1/0
R1(config-if)#ip address 10.1.12.1 255.255.255.0
R1(config-if)#clock rate 128000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int loopback 1
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ip ospf network point-to-point
R1(config-if)#exit
R1(config)#int loopback 30
R1(config-if)#ip address 172.30.30.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#ip ospf network point-to-point
R1(config-if)#exit

R2#conf t
R2(config)#int s1/0
R2(config-if)#ip address 10.1.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int s1/1
R2(config-if)#ip address 10.1.23.2 255.255.255.0
R2(config-if)#clock rate 128000
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int loopback 2
R2(config-if)#ip address 10.1.2.1 255.255.255.0
R2(config-if)#ip ospf network point-to-point
R2(config-if)#no shutdown
R2(config-if)#exit

R3#conf t
R3(config)#int s1/1
R3(config-if)#ip address 10.1.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int loopback 3
R3(config-if)#ip address 10.1.3.1 255.255.255.0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int loopback 100
R3(config-if)#ip address 192.168.100.1 255.255.255.0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int loopback 101
R3(config-if)#ip address 192.168.101.1 255.255.255.0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int loopback 102
R3(config-if)#ip address 192.168.102.1 255.255.255.0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int loopback 103
R3(config-if)#ip address 192.168.103.1 255.255.255.0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#no shutdown
R3(config-if)#exit

Configurar el protocolo de enrutamiento OSPF 1 área 0 entre R1 y R2, OSPF 1 área 23 entre R2 y R3, y OSPF 1 área 100 en R3.

No incluir a la L30 de R1 porque es una conexión externa, no es OSPF.

ÁREA 0

R1(config)#router ospf 1
R1(config-router)#network 10.1.12.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.255 area 0
R1(config-router)#exit

R2(config)#router ospf 1
R2(config-router)#network 10.1.2.0 0.0.0.255 area 0
R2(config-router)#network 10.1.12.0 0.0.0.255 area 0
R2(config-router)#exit

ÁREA 23

R2(config)#router ospf 1
R2(config-router)#network 10.1.23.0 0.0.0.255 area 23
R2(config-router)#exit

R3(config)#router ospf 1
R3(config-router)#network 10.1.23.0 0.0.0.255 area 23
R3(config-router)#network 10.1.3.0 0.0.0.255 area 23

ÁREA 100

R3(config-router)#network 192.168.100.0 0.0.0.255 area 100
R3(config-router)#network 192.168.101.0 0.0.0.255 area 100
R3(config-router)#network 192.168.102.0 0.0.0.255 area 100
R3(config-router)#network 192.168.103.0 0.0.0.255 area 100
R3(config-router)#exit

Chequear conectividad entre el área 0 y el área 23, y entre el área 0 y el área 100.  Comentar.

ÁREA 0 y 23

R1#ping 10.1.3.1 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/40/68 ms

ÁREA 0 y 100

R1#ping 192.168.100.1 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
…..
Success rate is 0 percent (0/5)

El area 0 y la 23 estan conectadas directamente, sin embargo el area 100 no lo esta.

¿Cuál es el ID de R2?
Router ID 10.1.2.1

¿Cuál es el ID de R3?
Router ID 192.168.103.1

¿Qué router es DR?
Ningun router es DR ya que no existen enlaces fastethernet. Todas las conexiones son seriales y la informacion es mostrada de la siguiente forma:
FULL/  –

Crear el enlace virtual entre R2 y R3 para darle conectividad al área 100.

R2(config)#router ospf 1
R2(config-router)#area 23 virtual-link 192.168.103.1
R2(config-router)#exit

R3(config)#router ospf 1
R3(config-router)#area 23 virtual-link 10.1.2.1
R3(config-router)#exit

Probar conectividad entre el área 0 y el área 100. Comentar.

R1#ping 192.168.100.1 source 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/47/64 ms

Al crear el virtual-link, el area 100 se conecta con el area 0.

Sumarizar manualmente las redes del área 100.

R3(config)#router ospf 1
R3(config-router)#area 100 range 192.168.100.0 255.255.252.0
R3(config-router)#exit

Para sumarizar calculamos la cantidad total de IPs que dan las redes, en este caso desde la 100.0 hasta la 103.0
El total es de 1024 (4 redes x 256 hosts = 1024).
La mascara para 1024 hosts es 255.255.252.0

Revisar las tablas de enrutamiento en los tres routers.

R1#sh ip route
172.30.0.0/30 is subnetted, 1 subnets
C       172.30.30.0 is directly connected, Loopback30
10.0.0.0/24 is subnetted, 5 subnets
C       10.1.12.0 is directly connected, Serial1/0
O IA    10.1.3.0 [110/129] via 10.1.12.2, 00:10:55, Serial1/0
O       10.1.2.0 [110/65] via 10.1.12.2, 00:10:55, Serial1/0
C       10.1.1.0 is directly connected, Loopback1
O IA    10.1.23.0 [110/128] via 10.1.12.2, 00:10:55, Serial1/0
O IA 192.168.100.0/22 [110/129] via 10.1.12.2, 00:03:45, Serial1/0

R2#sh ip route
10.0.0.0/24 is subnetted, 5 subnets
C       10.1.12.0 is directly connected, Serial1/0
O       10.1.3.0 [110/65] via 10.1.23.3, 00:11:19, Serial1/1
C       10.1.2.0 is directly connected, Loopback2
O       10.1.1.0 [110/65] via 10.1.12.1, 00:11:09, Serial1/0
C       10.1.23.0 is directly connected, Serial1/1
O IA 192.168.100.0/22 [110/65] via 10.1.23.3, 00:04:00, Serial1/1

R3#sh ip route
10.0.0.0/24 is subnetted, 5 subnets
O       10.1.12.0 [110/128] via 10.1.23.2, 00:04:17, Serial1/1
C       10.1.3.0 is directly connected, Loopback3
O       10.1.2.0 [110/65] via 10.1.23.2, 00:04:17, Serial1/1
O       10.1.1.0 [110/129] via 10.1.23.2, 00:04:17, Serial1/1
C       10.1.23.0 is directly connected, Serial1/1
C    192.168.102.0/24 is directly connected, Loopback102
C    192.168.103.0/24 is directly connected, Loopback103
C    192.168.100.0/24 is directly connected, Loopback100
C    192.168.101.0/24 is directly connected, Loopback101
O    192.168.100.0/22 is a summary, 00:04:17, Null0

Generar una ruta por defecto en OSPF.

R1(config)#router ospf 1
R1(config-router)#default-information originate always
R1(config-router)#exit

Revisar las tablas de enrutamiento.
Probar conectividad a la L30 desde el área 100.

Se agregó la siguiente linea en R3 que da acceso a la Loopback 30
O*E2 0.0.0.0/0 [110/1] via 10.1.23.2, 00:01:27, Serial1/1

R3#ping 172.30.30.1 source 192.168.103.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.30.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.103.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/50/108 ms

¿qué es un ABR?
Router de borde entre áreas distintas. En este caso R2 es un ABR.

¿cuál es el propósito de un enlace virtual?
Enlazar áreas que no están conectadas directamente con el área 0.

¿qué tipo de ruta es la indicada como O IA?
Rutas de otras areas.

¿cómo OSPF muestra en la tabla de enrutamiento una ruta externa a su área?
O*E2 0.0.0.0/0 [110/1] via 10.1.23.2, 00:01:27, Serial1/1

¡Apoya mi página para que pueda seguir publicando más contenido interesante!
Tu donación es crucial para mantenerla activa y continuar compartiendo artículos de calidad.
¡Gracias por tu apoyo continuo!
Paypal

Comparte en redes
Sobre el administrador

Soy un ingeniero en conectividad y redes amante de la música y todo tipo de tecnologías.

Entradas similares
0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments