Laboratorio EIGRP


Este laboratorio EIGRP se basará en la imagen anterior y tendrá por objetivo realizar la convergencia con el protocolo EIGRP. Para eso, deberemos seguir los siguientes pasos.

Desarrollo:

  1. Configurar las direcciones IP de las interfaces.
  2. Aplicar enrutamiento con EIGRP SA 23.
  3. Verificar la información de las tablas de EIGRP. Probar conectividad entre las loopback.

 

La configuración además debe cumplir los siguientes requisitos:

  1. Modificar el ancho de banda en el enlace serial entre R1 y R3 a 128000 bps.
  2. Evitar que los mensajes de EIGRP sean enviados a las interfaces loopback.
  3. Permitir a R2 hacer balanceo de carga (con métricas desiguales) entre 2 rutas.
  4. Aplicar autenticación a EIGRP con password simple entre R1 y R3. (password: cisco1).
  5. Aplicar autenticación a EIGRP usando MD5 entre R3 y R4. (password: cisco2).
  6. Configurar R4 para que informe una ruta resumen de las loopback 41, 42, 43 y 44.

 

Desarrollo ejercicio

Configurar las direcciones IP de las interfaces

R1#conf t
R1(config)#int f0/0
R1(config-if)#ip address 192.168.60.1 255.255.255.240
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config-if)#exit
R1(config)#int s1/0
R1(config-if)#ip address 20.0.0.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int s1/1
R1(config-if)#ip address 20.0.0.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

R2#conf t
R2(config)#int f0/0
R2(config-if)#ip address 192.168.60.2 255.255.255.240
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int s1/0
R2(config-if)#ip address 20.0.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int loopback 2
R2(config-if)#ip address 10.10.2.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit

R3#conf t
R3(config)#int f0/0
R3(config-if)#ip address 192.168.60.3 255.255.255.240
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int s1/1
R3(config-if)#ip address 20.0.0.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int s1/0
R3(config-if)#ip address 20.0.0.9 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit

R4#conf t
R4(config)#int s1/0
R4(config-if)#ip address 20.0.0.10 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int loopback 41
R4(config-if)#ip address 40.10.64.1 255.255.224.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int loopback 42
R4(config-if)#ip address 40.10.128.1 255.255.240.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int loopback 43
R4(config-if)#ip address 40.10.144.1 255.255.254.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int loopback 44
R4(config-if)#ip address 40.10.146.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit

Aplicar enrutamiento con EIGRP SA 23

R1(config)#router eigrp 23
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.60.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 20.0.0.4
R1(config-router)#exit

R2(config)#router eigrp 23
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.60.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 10.10.2.0
R2(config-router)#exit

R3(config)#router eigrp 23
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.60.0
R3(config-router)#network 20.0.0.4
R3(config-router)#network 20.0.0.8
R3(config-router)#exit

R4(config)#router eigrp 23
R4(config-router)#no auto-summary
R4(config-router)#network 20.0.0.8
R4(config-router)#network 40.10.64.0
R4(config-router)#network 40.10.128.0
R4(config-router)#network 40.10.144.0
R4(config-router)#network 40.10.146.0
R4(config-router)#exit

Verificar la información de las tablas de EIGRP. Probar conectividad entre las loopback.

R1#sh ip route
192.168.60.0/28 is subnetted, 1 subnets
C       192.168.60.0 is directly connected, FastEthernet0/0
20.0.0.0/30 is subnetted, 3 subnets
C       20.0.0.4 is directly connected, Serial1/1
C       20.0.0.0 is directly connected, Serial1/0
D       20.0.0.8 [90/2172416] via 192.168.60.3, 00:03:57, FastEthernet0/0
40.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
D       40.10.64.0/19 [90/2300416] via 192.168.60.3, 00:02:44, FastEthernet0/0
D       40.10.128.0/20
[90/2300416] via 192.168.60.3, 00:02:44, FastEthernet0/0
D       40.10.146.0/24
[90/2300416] via 192.168.60.3, 00:02:44, FastEthernet0/0
D       40.10.144.0/23
[90/2300416] via 192.168.60.3, 00:02:44, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
D       10.10.2.0 [90/156160] via 192.168.60.2, 00:03:58, FastEthernet0/0

R2#sh ip route
192.168.60.0/28 is subnetted, 1 subnets
C       192.168.60.0 is directly connected, FastEthernet0/0
20.0.0.0/30 is subnetted, 3 subnets
D       20.0.0.4 [90/20514560] via 192.168.60.3, 00:04:54, FastEthernet0/0
[90/20514560] via 192.168.60.1, 00:04:54, FastEthernet0/0
C       20.0.0.0 is directly connected, Serial1/0
D       20.0.0.8 [90/2172416] via 192.168.60.3, 00:04:54, FastEthernet0/0
40.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
D       40.10.64.0/19 [90/2300416] via 192.168.60.3, 00:03:41, FastEthernet0/0
D       40.10.128.0/20
[90/2300416] via 192.168.60.3, 00:03:41, FastEthernet0/0
D       40.10.146.0/24
[90/2300416] via 192.168.60.3, 00:03:41, FastEthernet0/0
D       40.10.144.0/23
[90/2300416] via 192.168.60.3, 00:03:42, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
C       10.10.2.0 is directly connected, Loopback2

R3#sh ip route
192.168.60.0/28 is subnetted, 1 subnets
C       192.168.60.0 is directly connected, FastEthernet0/0
20.0.0.0/30 is subnetted, 3 subnets
C       20.0.0.4 is directly connected, Serial1/1
D       20.0.0.0 [90/2172416] via 192.168.60.2, 00:05:39, FastEthernet0/0
[90/2172416] via 192.168.60.1, 00:05:39, FastEthernet0/0
C       20.0.0.8 is directly connected, Serial1/0
40.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
D       40.10.64.0/19 [90/2297856] via 20.0.0.10, 00:04:26, Serial1/0
D       40.10.128.0/20 [90/2297856] via 20.0.0.10, 00:04:26, Serial1/0
D       40.10.146.0/24 [90/2297856] via 20.0.0.10, 00:04:26, Serial1/0
D       40.10.144.0/23 [90/2297856] via 20.0.0.10, 00:04:26, Serial1/0
10.0.0.0/30 is subnetted, 1 subnets
D       10.10.2.0 [90/156160] via 192.168.60.2, 00:05:40, FastEthernet0/0

R4#sh ip route
192.168.60.0/28 is subnetted, 1 subnets
D       192.168.60.0 [90/2172416] via 20.0.0.9, 00:05:14, Serial1/0
20.0.0.0/30 is subnetted, 3 subnets
D       20.0.0.4 [90/21024000] via 20.0.0.9, 00:05:14, Serial1/0
D       20.0.0.0 [90/2684416] via 20.0.0.9, 00:05:14, Serial1/0
C       20.0.0.8 is directly connected, Serial1/0
40.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
C       40.10.64.0/19 is directly connected, Loopback41
C       40.10.128.0/20 is directly connected, Loopback42
C       40.10.146.0/24 is directly connected, Loopback44
C       40.10.144.0/23 is directly connected, Loopback43
10.0.0.0/30 is subnetted, 1 subnets
D       10.10.2.0 [90/2300416] via 20.0.0.9, 00:05:14, Serial1/0

R2#ping 40.10.64.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.10.64.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/39/64 ms

R2#ping 40.10.128.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.10.128.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/49/64 ms

R2#ping 40.10.144.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.10.144.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/88 ms

R2#ping 40.10.146.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.10.146.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/41/96 ms

R4#ping 10.10.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/46/92 ms

Modificar el ancho de banda en el enlace serial entre R1 y R3 a 128000 bps.

R1(config)#int s1/1
R1(config-if)#bandwidth 128
R1(config-if)#exit

R3(config)#int s1/1
R3(config-if)#bandwidth 128
R3(config-if)#exit

Evitar que los mensajes de EIGRP sean enviados a las interfaces loopback.

R2(config)#router eigrp 23
R2(config-router)#passive-interface loopback 2
R2(config-router)#exit

R4(config)#router eigrp 23
R4(config-router)#passive-interface loopback 41
R4(config-router)#passive-interface loopback 42
R4(config-router)#passive-interface loopback 43
R4(config-router)#passive-interface loopback 44
R4(config-router)#exit

Permitir a R2 hacer balanceo de carga (con métricas desiguales) entre 2 rutas.

R2(config)#router eigrp 23
R2(config-router)#variance 2
R2(config-router)#exit

Aplicar autenticación a EIGRP con password simple entre R1 y R3. (password: cisco1).

R1(config)#key chain EIGRP-KEYS
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string cisco1
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#int s1/1
R1(config-if)#ip authentication key-chain eigrp 23 EIGRP-KEYS
R1(config-if)#exit

R3(config)#key chain EIGRP-KEYS
R3(config-keychain-key)#key-string cisco1
R3(config-keychain-key)#exit
R3(config-keychain)#exit
R3(config)#int s1/1
R3(config-if)#ip authentication key-chain eigrp 23 EIGRP-KEYS
R3(config-if)#exit

Aplicar autenticación a EIGRP usando MD5 entre R3 y R4. (password: cisco2).

R3(config)#key chain EIGRP-KEYS2
R3(config-keychain-key)#key-string cisco2
R3(config-keychain-key)#exit
R3(config-keychain)#exit
R3(config)#int s1/0
R3(config-if)#ip authentication key-chain eigrp 23 EIGRP-KEYS2
R3(config-if)#ip authentication mode eigrp 23 md5
R3(config-if)#exit

R4(config)#key chain EIGRP-KEYS2
R4(config-keychain-key)#key-string cisco2
R4(config-keychain-key)#exit
R4(config-keychain)#exit
R4(config)#int s1/0
R4(config-if)#ip authentication key-chain eigrp 23 EIGRP-KEYS2
R4(config-if)#ip authentication mode eigrp 23 md5
R4(config-if)#exit

Configurar R4 para que informe una ruta resumen de las loopback 41, 42, 43 y 44.

R4(config)#router eigrp 23
R4(config-router)#auto-summary
R4(config-router)#exit
R4(config)#int s1/0
R4(config-if)#ip summary-address eigrp 23 40.10.0.0 255.255.0.0
R4(config-if)#exit