Ejercicio tipo examen CCNP1


Este ejercicio tipo examen CCNP1 integra los protocolos EIGRP, OSPF y BGP los cuales fueron enseñados durante todo el quinto semestre de la carrera.

El ejercicio se basará en la siguiente tooplogía.

1.- CONFIGURAR LAS INTERFACES FÍSICAS Y LÓGICAS.

R1#conf t
R1(config)#int lo 12
R1(config-if)#ip address 172.10.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ip ospf network point-to-point
R1(config-if)#exit
R1(config)#int lo 13
R1(config-if)#ip address 172.10.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#ip ospf network point-to-point
R1(config-if)#exit
R1(config)#int lo 10
R1(config-if)#ip address 172.10.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int lo 11
R1(config-if)#ip address 172.10.11.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int s1/1
R1(config-if)#ip address 10.1.2.1 255.255.255.0
R1(config-if)#clock rate 128000
R1(config-if)#no shutdown
R1(config-if)#ex
R1(config)#int s1/0
R1(config-if)#ip address 10.2.3.1 255.255.255.0
R1(config-if)#clock rate 128000
R1(config-if)#no shutdown
R1(config-if)#ex

R2#conf t
R2(config)#int lo 20
R2(config-if)#ip address 172.10.20.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#ex
R2(config)#int lo 21
R2(config-if)#ip address 172.10.21.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#ex
R2(config)#int s1/0
R2(config-if)#ip address 10.1.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#ex
R2(config)#int f0/0
R2(config-if)#ip address 10.4.3.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#ex

R3#conf t
R3(config)#int lo 30
R3(config-if)#ip address 172.10.30.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#ip ospf network point-to-point
R3(config-if)#ex
R3(config)#int lo 31
R3(config-if)#ip address 172.10.31.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#ip ospf network point-to-point
R3(config-if)#ex
R3(config)#int s1/1
R3(config-if)#ip address 10.2.3.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#ex
R3(config)#int f0/1
R3(config-if)#ip address 10.3.4.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#ex

R4#conf t
R4(config)#int lo 40
R4(config-if)#ip address 172.10.40.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#ex
R4(config)#int lo 41
R4(config-if)#ip address 172.10.41.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#ex
R4(config)#int f0/1
R4(config-if)#ip address 10.3.4.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#ex
R4(config)#int f0/0
R4(config-if)#ip address 10.4.3.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#ex

2.- CONFIGURAR EL PROTOCOLO OSPF 20 ÁREA 0 Y ÁREA 1. EVITAR QUE LOS MENSAJES OSPF SEAN ENVIADOS A R4.

R3(config)#router osp
R3(config)#router ospf 20
R3(config-router)#network 172.10.30.0 0.0.0.255 area 0
R3(config-router)#network 172.10.31.0 0.0.0.255 area 0
R3(config-router)#network 10.2.3.0 0.0.0.255 area 0
R3(config-router)#passive-interface f0/1
R3(config-router)#ex

R1(config)#router ospf 20
R1(config-router)#network 10.2.3.0 0.0.0.255 area 0
R1(config-router)#network 172.10.12.0 0.0.0.255 area 1
R1(config-router)#network 172.10.13.0 0.0.0.255 area 1
R1(config-router)#passive-interface s1/1
R1(config-router)#ex

3.- CONFIGURAR EL PROTOCOLO EIGRP SA 100. EVITAR QUE LOS MENSAJES EIGRP SEAN ENVIADOS A R4.

R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R1(config-router)#network 10.1.2.0 0.0.0.255
R1(config-router)#network 172.10.10.0 0.0.0.255
R1(config-router)#network 172.10.11.0 0.0.0.255
R1(config-router)#passive-interface s1/0
R1(config-router)#ex

R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#network 10.1.2.0 0.0.0.255
R2(config-router)#network 172.10.20.0 0.0.0.255
R2(config-router)#network 172.10.21.0 0.0.0.255
R2(config-router)#passive-interface f0/0
R2(config-router)#ex

4.- APLICAR REDISTRIBUCIÓN ENTRE EIGRP Y OSPF.

Para EIGRP aplicar los siguientes parámetros para la métrica:

  • ancho de banda: 10 MBPS
  • retardo: 100 microseg.
  • confiabilidad: máxima
  • carga: 50%
  • MTU: 1500.

Para OSPF usar la métrica por defecto.

R1(config)#router eigrp 100
R1(config-router)#redistribute ospf 20 metric 10000 100 255 128 1500
R1(config-router)#ex

R1(config)#router ospf 20
R1(config-router)#redistribute eigrp 100 subnets
R1(config-router)#ex

5.- APLICAR LAS SIGUIENTES RESTRICCIONES AL PROCESO DE REDISTRIBUCIÓN:

las redes L20 y L21 deben ser conocidas por OSPF como E1, y
las redes del área 1 de OSPF no deben ser conocidas por EIGRP.

R1(config)#access-list 1 permit 172.10.20.0
R1(config)#access-list 1 permit 172.10.21.0
R1(config)#route-map E12021 permit 10
R1(config-route-map)#match ip address 1
R1(config-route-map)#set metric-type type-1
R1(config-route-map)#ex
R1(config)#router ospf 20
R1(config-router)#redistribute eigrp 100 subnets route-map E12021
R1(config-router)#ex

R1(config)#access-list 2 permit 172.10.12.0
R1(config)#access-list 2 permit 172.10.13.0
R1(config)#route-map DENYAREA1 deny 10
R1(config-route-map)#match ip address 2
R1(config-route-map)#ex
R1(config)#route-map DENYAREA1 permit 20
R1(config-route-map)#ex
R1(config)#router eigrp 100
R1(config-router)#redistribute ospf 20 metric 10000 100 255 128 1500 route-map DENYAREA1
R1(config-router)#ex

6.- CONFIGURAR SESIONES IBGP FULL MESH, PARA ESTO UTILIZAR LAS INTERFACES LOOPBACK L10, L20 Y L30 SEGÚN CORRESPONDA. PUBLICAR TODAS LAS INTERFACES LOOPBACK EN BGP.

R2(config)#router bgp 1
R2(config-router)#neighbor 172.10.10.1 remote-as 1
R2(config-router)#neighbor 172.10.10.1 update-source lo 20
R2(config-router)#neighbor 172.10.10.1 next-hop-self
R2(config-router)#neighbor 172.10.30.1 remote-as 1
R2(config-router)#neighbor 172.10.30.1 update-source lo 20
R2(config-router)#neighbor 172.10.30.1 next-hop-self
R2(config-router)#ex

R1(config)#router bgp 1
R1(config-router)#neighbor 172.10.20.1 remote-as 1
R1(config-router)#neighbor 172.10.20.1 update-source lo 10
R1(config-router)#neighbor 172.10.20.1 next-hop-self
R1(config-router)#neighbor 172.10.30.1 remote-as 1
R1(config-router)#neighbor 172.10.30.1 update-source lo 10
R1(config-router)#neighbor 172.10.30.1 next-hop-self
R1(config-router)#ex

R3(config)#router bgp 1
R3(config-router)#neighbor 172.10.20.1 remote-as 1
R3(config-router)#neighbor 172.10.20.1 update-source lo 30
R3(config-router)#neighbor 172.10.20.1 next-hop-self
R3(config-router)#neighbor 172.10.10.1 remote-as 1
R3(config-router)#neighbor 172.10.10.1 update-source lo 30
R3(config-router)#neighbor 172.10.10.1 next-hop-self
R3(config-router)#ex

7.- CONFIGURAR LAS SESIONES EBGP ENTRE LOS ROUTERS R2-R4 Y R3-R4, A TRAVÉS DE LAS INTERFACES DIRECTAMENTE CONECTADAS. EN R4 PUBLICAR LAS LOOPBACK.

R2(config)#router bgp 1
R2(config-router)#neighbor 10.4.3.1 remote-as 2
R2(config-router)#network 172.10.20.0 mask 255.255.255.0
R2(config-router)#network 172.10.21.0 mask 255.255.255.0
R2(config-router)#network 10.1.2.0 mask 255.255.255.0
R2(config-router)#ex

R1(config)#router bgp 1
R1(config-router)#network 172.10.10.0 mask 255.255.255.0
R1(config-router)#network 172.10.11.0 mask 255.255.255.0
R1(config-router)#network 172.10.12.0 mask 255.255.255.0
R1(config-router)#network 172.10.13.0 mask 255.255.255.0
R1(config-router)#ex

R3(config)#router bgp 1
R3(config-router)#neighbor 10.3.4.1 remote-as 2
R3(config-router)#network 172.10.30.0 mask 255.255.255.0
R3(config-router)#network 172.10.31.0 mask 255.255.255.0
R3(config-router)#network 10.2.3.0 mask 255.255.255.0
R3(config-router)#ex

R4(config)#router bgp 2
R4(config-router)#neighbor 10.4.3.2 remote-as 1
R4(config-router)#neighbor 10.3.4.2 remote-as 1
R4(config-router)#network 172.10.40.0 mask 255.255.255.0
R4(config-router)#network 172.10.41.0 mask 255.255.255.0
R4(config-router)#ex

8.- APLICAR UN ATRIBUTO DE BGP PARA QUE EL SA 1 SE COMUNIQUE CON EL SA 2 A TRAVÉS DE R2.

R2(config)#route-map PRIMARIO permit 10
R2(config-route-map)#set local-preference 150
R2(config-route-map)#ex
R2(config)#router bgp 1
R2(config-router)#neighbor 10.4.3.1 route-map PRIMARIO in
R2(config-router)#exit

R3(config)#route-map SECUNDARIO permit 10
R3(config-route-map)#set local-preference 125
R3(config-route-map)#ex
R3(config-router)#neighbor 10.3.4.1 route-map SECUNDARIO in
R3(config-router)#ex

R2(config)#do clear ip bgp *

9.- APLICAR UN ATRIBUTO DE BGP PARA QUE EL SA 2 SE COMUNIQUE CON EL SA 1 A TRAVÉS DE R3.

R4(config)#router bgp 2
R4(config-router)#neighbor 10.3.4.2 weight 200
R4(config-router)#neighbor 10.4.3.2 weight 100
R4(config-router)#exit
R4(config)#do clear ip bgp *

10.- CONFIGURAR LAS INTERFACES LOOPBACK IPV6 EN R2 Y R3. CREAR UN TÚNEL QUE PERMITA COMUNICAR AMBOS ROUTERS POR IPV6. HABILITAR OSPFV3 PARA EL ENRUTAMIENTO.

R2(config)#int lo 50
R2(config-if)#ipv6 address a111::1/112
R2(config-if)#no shutdown
R2(config-if)#ex

R3(config)#int lo 51
R3(config-if)#ipv6 address f222::1/64
R3(config-if)#no shutdown
R3(config-if)#ex

R2(config)#ipv6 unicast-routing
R2(config)#ipv6 router ospf 1
R2(config-rtr)#ex
R2(config)#int tunnel 0
R2(config-if)#tunnel mode ipv6ip
R2(config-if)#tunnel source s1/0
R2(config-if)#tunnel destination 10.2.3.2
R2(config-if)#ipv6 address c333::1/112
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#no shutdown
R2(config-if)#ex
R2(config)#int lo 50
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#ex

R3(config)#ipv6 unicast-routing
R3(config)#ipv6 router ospf 1
R3(config-rtr)#ex
R3(config)#int tunnel 0
R3(config-if)#tunnel mode ipv6ip
R3(config-if)#tunnel source s1/1
R3(config-if)#tunnel destination 10.1.2.2
R3(config-if)#ipv6 address c333::2/112
R3(config-if)#ipv6 ospf 1 area 0
R3(config-if)#no shutdown
R3(config-if)#ex
R3(config)#int lo 51
R3(config-if)#ipv6 ospf 1 area 0
R3(config-if)#ex