Ejercicio 1 de OSPF


Ejercicio 1 de OSPF

El ejercicio 1 de OSPF es el primero de muchos ejercicios resueltos de CISCO que subiré en las próximas semanas. Intentaré incluir imágenes cuando corresponda y pondré los comandos necesarios para resolverlos.

Pueden descargar el ejercicio (sin resolver) desde ESTE ENLACE.

Ejercicio 1 de OSPF

Resolviendo el ejercicio

Lo primero que haremos será verificar la información del servidor.
Click en el servidor e ir a la pestaña Desktop para confirmar el IP que posee.

Como vemos, el servidor es WEB y DNS. Debemos revisar la configuración que corresponda.

Habiendo confirmado las configuraciones del servidor, podemos continuar con los routers y PCs.

Configuración R1

Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#int f0/0
R1(config-if)#ip address 10.10.20.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int f0/1
R1(config-if)#ip address 10.10.40.1 255.255.255.240
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int lo 1
R1(config-if)#ip address 30.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

Configuración PC0

IP Configuration
Static
IP Address 10.10.20.2
Subnet Mask 255.255.255.0
Default Gateway 10.10.20.1
DNS Server 10.10.40.10

Configuración R2

Router>
Router>en
Router#conf t
Router(config)#hostname R2
R2(config)#int f0/0
R2(config-if)#ip address 10.10.30.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int f0/1
R2(config-if)#ip address 10.10.40.2 255.255.255.240
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int lo 2
R2(config-if)#ip address 30.2.2.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit

Configuración PC1

IP Configuration
Static
IP Address 10.10.30.2
Subnet Mask 255.255.255.0
Default Gateway 10.10.30.1
DNS Server 10.10.40.10

Configuración R3

Router>en
Router#conf t
Router(config)#hostname R3
R3(config)#int f0/1
R3(config-if)#ip address 10.10.40.3 255.255.255.240
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int s0/0/0
R3(config-if)#ip address 20.0.0.1 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int lo 3
R3(config-if)#ip address 30.3.3.1 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit

Configuración R4

Router>en
Router#conf t
Router(config)#hostname R4
R4(config)#int s0/0/0
R4(config-if)#ip address 20.0.0.2 255.255.255.252
R4(config-if)#clock rate 128000
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int s0/0/1
R4(config-if)#ip address 20.0.0.5 255.255.255.252
R4(config-if)#clock rate 128000
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#int lo 4
R4(config-if)#ip address 30.4.4.1 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit

Configuración R5

Router>en
Router#conf t
Router(config)#hostname R5
R5(config)#int s0/0/1
R5(config-if)#ip address 20.0.0.6 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#int f0/0
R5(config-if)#ip address 192.168.1.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#int lo 5
R5(config-if)#ip address 30.5.5.1 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit

Configuración PC2

IP Configuration
Static
IP Address 192.168.1.2
Subnet Mask 255.255.255.0
Default Gateway 192.168.1.1
DNS Server 10.10.40.10

Configuración OSPF R1 área 0

R1(config)#router ospf 1
R1(config-router)#network 10.10.20.0 0.0.0.255 area 0
R1(config-router)#network 10.10.40.0 0.0.0.15 area 0
R1(config-router)#network 30.1.1.0 0.0.0.3 area 0
R1(config-router)#exit

Configuración OSPF R2 área 0

Router(config)#router ospf 1
Router(config-router)#network 10.10.30.0 0.0.0.255 area 0
Router(config-router)#network 10.10.40.0 0.0.0.15 area 0
Router(config-router)#network 30.2.2.0 0.0.0.3 area 0
Router(config-router)#exit

Configuración OSPF R3 área 0

R3(config)#router ospf 1
R3(config-router)#network 10.10.40.0 0.0.0.15 area 0
R3(config-router)#network 30.3.3.0 0.0.0.3 area 0
R3(config-router)#exit

Configuración OSPF R3 área 10

R3(config)#router ospf 1
R3(config-router)#network 20.0.0.0 0.0.0.3 area 10
R3(config-router)#exit

Configuración OSPF R4 área 10

R4(config)#router ospf 1
R4(config-router)#network 20.0.0.0 0.0.0.3 area 10
R4(config-router)#exit

Configuración OSPF R4 área 20

R4(config)#router ospf 1
R4(config-router)#network 20.0.0.4 0.0.0.3 area 20
R4(config-router)#network 30.4.4.0 0.0.0.3 area 20
R4(config-router)#exit

Configuración OSPF R5 área 20

R5(config)#router ospf 1
R5(config-router)#network 20.0.0.4 0.0.0.3 area 20
R5(config-router)#network 192.168.1.0 0.0.0.255 area 20
R5(config-router)#network 30.5.5.0 0.0.0.3 area 20
R5(config-router)#exit

Hasta este momento solo hay conectividad entre el area 0 y el area 10.
El ultimo IP accesible es el 20.0.0.2.

Para crear el virtual-link debemos saber el ID de los routers que unen el area 0 con el area 20.
En este caso R3 y R4.

ID R3

R3#sh ip protocols
Routing Protocol is "ospf 1"
Router ID 30.3.3.1

ID R4

R4#sh ip protocols
Routing Protocol is "ospf 1"
Router ID 30.4.4.1

Configuración virtual-link R3

R3(config)#router ospf 1
R3(config-router)#area 10 virtual-link 30.4.4.1
R3(config-router)#exit

Configuración virtual-link R4

R4(config)#router ospf 1
R4(config-router)#area 10 virtual-link 30.3.3.1
R4(config-router)#exit

 

CONECTIVIDAD TOTAL

Responder:

1.- ¿Cuál es el router designado el área 0?
R: Con el comando show ip ospf neighbor es posible ver el estado de los Routers vecinos.

R2#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
30.1.1.1 1 FULL/DR 00:00:38 10.10.40.1 FastEthernet0/1
30.3.3.1 1 FULL/DROTHER 00:00:30 10.10.40.3 FastEthernet0/1

En R2 podemos ver el DR con el ID 30.1.1.1

Con el comando show ip protocols podemos saber el ID del router

R1#sh ip protocols
Router ID 30.1.1.1

En R1, el ID es de 30.1.1.1

El router designado (DR) del area 0 es el R1

2.- ¿Cuál es el router designado en el área 20?
R: Siguiendo los mismos pasos anteriores, el DR del area 20 es ninguno.

3.- ¿Qué routers son ABR?
R: Los routers de borde que unen las áreas, en este caso R3 y R4
También podemos verificar con el comando show ip ospf border-routers en R1

R1#sh ip ospf border-routers
OSPF Process 1 internal Routing Table
Codes: i - Intra-area route, I - Inter-area route
i 30.3.3.1 [1] via 10.10.40.3, FastEthernet0/1, ABR, Area 0, SPF 1
i 30.4.4.1 [65] via 10.10.40.3, FastEthernet0/1, ABR, Area 0, SPF 65

Vemos que los routers con ID 30.3.3.1 y 30.4.4.1 son ABR (R3 y R4).

4.- ¿Qué es un enlace virtual en OSPF?
R: La conexión entre el área 0 y otra área que no está conectada directamente con esta.

5.- ¿Qué significa que una interfaz tenga prioridad 0?
R: Que el router no puede ser elegido como DR o BDR.

El ejercicio resuelto lo pueden descargar desde ESTE ENLACE.